Swish errors

Incident Report for BetterNow

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 13:12 UTC

Identified

Some Swish payments are failing due to an issue with our upstream vendor. More information can be found at https://status.quickpay.net/cmh1pki2m04p95kv5jg6tkw0a
Posted Oct 22, 2025 - 08:43 UTC
This incident affected: Donation Payment Processing.