Errors connecting to payment provider (QuickPay)
Incident Report for BetterNow
Resolved
This incident has been resolved.
Posted Oct 08, 2021 - 06:09 UTC
Monitoring
Quickpay's incident is here: https://status.quickpay.net/incidents/409

They are currently reporting that the issue is fixed, we will continue to monitor for errors
Posted Oct 08, 2021 - 05:36 UTC
Investigating
We are currently investigating this issue.
Posted Oct 08, 2021 - 05:33 UTC
This incident affected: Donation Payment Processing.