Problems with MobilePay online
Incident Report for BetterNow
Resolved
This incident has been resolved.
Posted Oct 12, 2021 - 12:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 12, 2021 - 10:43 UTC
Identified
Our payment provider is experiencing problems with MobilePay online transactions. Their status is here: https://status.quickpay.net/incidents/414

This does not affect card transactions or Swish or Vipps
Posted Oct 12, 2021 - 10:30 UTC
This incident affected: Donation Payment Processing.